Thursday, September 6, 2012

Problems while installing SharePoint 2010 on Windows Server 2012 RTM

I was recently following the following article in order to install SharePoint 2010 SP1 with June 2012 CU on Windows Server 2012 RTM:  http://blogs.msdn.com/b/bedwards/archive/2012/08/21/sharepoint-2010-on-windows-8-rtm-with-sql-server-2012-rtm.aspx

However, I came across an error message after running the SharePoint Product Configuration Wizard:


So, I first looked at my IIS configuration in IIS Manager and noticed that despite setting the default .Net Framework version in IIS Manager, my Application Pools were still created with .Net 4.0 compatibility.  So, of course, I had to change them back to .Net 2.0 compatibility:


I was then doing some more digging around in IIS and I found this setting:


 So it looked like the Application Pool Defaults were separate from the .Net Framework version defaults!!

So, of course, I looked at the Application Pool Defaults and sure enough, they were set to .Net 4.0:


In order to make sure everything would work correctly, I changed the Application Pool default .NET Framework version to v2.0:


After making those changes, my SharePoint Product Configuration Wizard was successful!!


1 comment:

  1. Thanks for all the information,it was very helpful and i really like that you are providing information on .net training ,being enrolled in .net freshers training with projects live training http://www.wiziq.com/course/57-fresher-training-projects i was looking for such .net fresher training to assist me and your information helped me a lot.Really like that you are providing such information . Thanks.

    ReplyDelete